Network Outage
Incident Report for MCN
Resolved
This incident has been resolved.
Posted Sep 07, 2020 - 16:45 HKT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 07, 2020 - 16:23 HKT
Update
It is further confirmed to be a China Telecom DWDM failure and we are still making every effort to restore service ASAP.
Posted Sep 07, 2020 - 13:43 HKT
Identified
This issue has been identified as fiber cut on HK side. We're continuing cooperating with Upstream to bring network up.

We apologize for any inconvenience.
Posted Sep 07, 2020 - 13:14 HKT
Investigating
There is a network outage between our CN - HK IEPL. We're still investigating with upstream.

This incident affects all customers.
Posted Sep 07, 2020 - 12:57 HKT
This incident affected: Relay Service (Standard IEPL Endpoints, Premium IEPL Endpoints) and Relay Infrastructure (CN - HK IEPL).